Scheduled Maintenance to upgrade critical hardware components
Scheduled for December 26, 2025 at 1:30 AM – 1:40 AM
Affects
SuprSend App
Under maintenance from 1:30 AM to 1:40 AM
Notification Engine
Under maintenance from 1:30 AM to 1:40 AM
APIs
Under maintenance from 1:30 AM to 1:40 AM
Dashboard API
Under maintenance from 1:30 AM to 1:40 AM
Object/Preferences API
Under maintenance from 1:30 AM to 1:40 AM
Management API
Under maintenance from 1:30 AM to 1:40 AM
Completed
December 26, 2025 at 1:40 AMCompleted
December 26, 2025 at 1:40 AMMaintenance has completed successfully.
In progress
December 26, 2025 at 1:30 AMIn progress
December 26, 2025 at 1:30 AMMaintenance is now in progress
Planned
December 26, 2025 at 1:30 AMPlanned
December 26, 2025 at 1:30 AMWe will be performing scheduled maintenance to upgrade critical hardware components of the SuprSend platform.
What to expect
• Workflow processing will be temporarily unavailable
• APIs will be inaccessible during the maintenance window
• All workflow triggers during this period will be safely queued
Once the maintenance is complete and services are fully restored, all queued workflows will be processed automatically. No data will be lost.
Why this maintenance is required
This upgrade is part of our ongoing efforts to improve the reliability, performance, and scalability of the SuprSend platform.
We will update this status page as the maintenance progresses and once services are fully operational.
Thank you for your patience and continued trust in SuprSend.